<div dir="ltr">Thanks, I had rvm installed and was using ruby-2.0.0-p0. <div><br></div><div style>For posterity:</div><div style><br></div><div style>    $ rvm use 1.9.2 </div><div style><br></div><div style>fixed the problem. </div>
</div><div class="gmail_extra"><br><br><div class="gmail_quote">On Tue, Apr 2, 2013 at 11:32 AM, Carlos Perez <span dir="ltr"><<a href="mailto:carlos_perez@darkoperator.com" target="_blank">carlos_perez@darkoperator.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I would open a ticket with them, they also now push Ruby 2.0 as default and that has problems with OpenSSL loading in Metasploit so you are forced to use chruby or RVM<br>

<div><div class="h5"><br>
On Apr 2, 2013, at 2:25 PM, fred concklin <<a href="mailto:fredconcklin@gmail.com">fredconcklin@gmail.com</a>> wrote:<br>
<br>
> Hi,<br>
><br>
> I have a feeling this might not be the right place, but I'm experiencing problems running msfupdate installed through homebrew.<br>
><br>
> $ brew install metasploit<br>
> $ msfupdate<br>
><br>
> [*]<br>
> [*] Attempting to update the Metasploit Framework...<br>
> [*]<br>
><br>
> /usr/local/bin/msfupdate:190:in `<main>': Cannot determine checkout type: `/usr/local/Cellar/metasploit/4.5.0-2013021301/libexec' (RuntimeError)<br>
><br>
> If anybody has come across this I'd appreciate input, otherwise I'll start looking into the homebrew formula / rvm communities for a fix.<br>
><br>
><br>
</div></div>> _______________________________________________<br>
> <a href="https://mail.metasploit.com/mailman/listinfo/framework" target="_blank">https://mail.metasploit.com/mailman/listinfo/framework</a><br>
<br>
</blockquote></div><br></div>