The <<<<<<<<<<< business indicates that you have a conflict in your svn checkout.<div><br></div><div>Looks like this guy had the same problem. Solution was to delete the conflicting files and msfupdate again.</div>
<div><br></div><div><a href="http://www.backtrack-linux.org/forums/showthread.php?t=51173&p=226622&viewfull=1#post226622">http://www.backtrack-linux.org/forums/showthread.php?t=51173&p=226622&viewfull=1#post226622</a></div>
<div><br></div><div><div><br><div class="gmail_quote">On Mon, Dec 3, 2012 at 3:48 PM, Manvir Singh Shergill <span dir="ltr"><<a href="mailto:mannigill1@gmail.com" target="_blank">mannigill1@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><blockquote>Hi,<br><br>I am getting syntax error when trying to update metasploit using command msfupdate.<br>
<br><br><i>msf > msfupdate[*] exec: msfupdate<br><br>/opt/metasploit/msf3/msfupdate:79: syntax error, unexpected tLSHFT, expecting $end<br>

<<<<<<< .mine</i><br><br>I am using Backtrack 5 R3 and when i tried to run metasploit I get more syntax errors. I have already tried apt-get update and apt-get upgrade<br><br><br><i>root@bt:~# msfconsole<br>


[-] WARNING! The following modules could not be loaded!<br>[-] /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb: SyntaxError /opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:35: syntax error, unexpected tLSHFT, expecting ')'<br>


<<<<<<< .mine<br>^<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:36: syntax error, unexpected tASSOC, expecting keyword_end<br>'Version' => '$Revision: 16005 $',<br>


^<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:36: syntax error, unexpected ',', expecting keyword_end<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:37: syntax error, unexpected tASSOC, expecting keyword_end<br>


'Platform' => [ 'windows' ],<br>^<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:37: syntax error, unexpected ',', expecting keyword_end<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:39: syntax error, unexpected tASSOC, expecting keyword_end<br>


'Version' => '$Revision: 16005 $',<br>^<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:39: syntax error, unexpected ',', expecting keyword_end<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:40: syntax error, unexpected tASSOC, expecting keyword_end<br>


'Platform' => [ 'win' ],<br>^<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:40: syntax error, unexpected ',', expecting keyword_end<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:42: syntax error, unexpected tASSOC, expecting keyword_end<br>


'SessionTypes' => [ 'meterpreter' ]<br>^<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:43: syntax error, unexpected ')', expecting keyword_end<br>))<br>^<br>/opt/metasploit/msf3/modules/post/windows/gather/credentials/outlook.rb:379: syntax error, unexpected $end, expecting keyword_end<br>


<br>IIIIII dTb.dTb _.---._<br>II 4' v 'B .'"".'/|`.""'.<br>II 6. .P : .' / | `. :<br>II 'T;. .;P' '.' / | `.'<br>II 'T; ;P' `. / | .'<br>IIIIII 'YvP' `-.__|__.-'<br>


<br>I love shells --egypt<br><br><br>=[ metasploit v4.5.0-dev [core:4.5 api:1.0]<br>+ -- --=[ 985 exploits - 540 auxiliary - 161 post<br>+ -- --=[ 262 payloads - 28 encoders - 8 nops<br><br></i><br>Please help </blockquote>


</div>
<br>_______________________________________________<br>
<a href="https://mail.metasploit.com/mailman/listinfo/framework" target="_blank">https://mail.metasploit.com/mailman/listinfo/framework</a><br>
<br></blockquote></div><br></div></div>